Quagga: OSPF Sederhana - dengan MD5 Authentication

From OnnoWiki
Jump to navigation Jump to search
Image6005.gif


Topologi

R1

e1 -- R3: e1
e2 -- R2: e1
e3 -- NAT: Internet

R2

e1 -- R1: e2
e2 -- R3: e2
e3 -- LAN 172.16.1.1

R3

e1 -- R1: e1
e2 -- R2: e2
e3 -- LAN 192.168.1.1

Konfigurasi

Router1:

vtysh
configure terminal
  interface eth1
    ip address 10.10.1.1/30
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface eth2
    ip address 10.10.1.5/30
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  !
  ! NAT GNS3 gw 192.168.122.1
  interface eth3
    ip address 192.168.122.100/24
    ip address 192.168.122.101/24
    ip address 192.168.122.102/24
    no shutdown
    ip route 0.0.0.0/0 192.168.122.1
  end

Router2:

vtysh
configure terminal
  interface eth1
    ip address 10.10.1.6/30
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface eth2
    ip address 10.10.1.9/30
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface eth3
    ip address 172.16.1.1/16
    no shutdown
    end

Router3:

vtysh
configure terminal
  interface eth1
    ip address 10.10.1.2/30
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface eth2
    ip address 10.10.1.10/30
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface eth3
    ip address 192.168.1.1/24
    no shutdown
    end

Ada tiga (3) elemen dasar konfigurasi OSPF:

  • Enable OSPF instance
  • OSPF area configuration
  • OSPF network configuration


Catatan: Ingat bahwa backbone area-id adalah 0.0.0.0.

R1

vtysh
configure terminal
  !
  ! area 0 = backbone
  router ospf
  network 10.10.1.0/30 area 0.0.0.0
  network 10.10.1.4/30 area 0.0.0.0
  area 0.0.0.0 authentication message-digest
  end

R2

vtysh
configure terminal
  !
  ! area 0 = backbone
  router ospf
  network 10.10.1.4/30 area 0.0.0.0
  network 10.10.1.8/30 area 0.0.0.0
  network 172.16.0.0/16 area 0.0.0.0
  area 0.0.0.0 authentication message-digest
  end

R3

vtysh
configure terminal
  !
  ! area 0 = backbone
  router ospf
  network 10.10.1.0/30 area 0.0.0.0
  network 10.10.1.8/30 area 0.0.0.0
  network 192.168.1.0/24 area 0.0.0.0
  area 0.0.0.0 authentication message-digest
  end

Verify

Cek di R1, R2, R3

show ip ospf neighbor
show ip ospf database 
show ip route


Referensi


Pranala Menarik