Quagga: OSPF Sederhana

From OnnoWiki
Jump to navigation Jump to search
Image6005.gif

Sambungan:

R1
eth1: -- R3: eth1
eth2: -- R2: eth1
eth3: -- Internet
R2:
eth1: -- R1: eth2
eth2: -- R3: eth2
eth3: -- LAN 172.16.1.1/16
R3:
eth1: -- R1: eth1
eth2: -- R2: eth2
eth3: -- LAN 192.168.1.1/24

Router1:

vtysh
configure terminal
  interface eth1
    ip address 10.10.1.1/30
    exit
  interface eth2
    ip address 10.10.1.5/30
    exit
  !
  ! NAT GNS3 gw 192.168.122.1
  interface eth3
    ip address 192.168.122.100/24
    ip address 192.168.122.101/24
    ip address 192.168.122.102/24
    ip route 0.0.0.0 0.0.0.0 192.168.122.1
  end

Router2:

vtysh
configure terminal
  interface eth1
    ip address 10.10.1.6/30
    exit
  interface eth2
    ip address 10.10.1.9/30
    exit
  interface eth3
    ip address 172.16.1.1/16
    end

Router3:

vtysh
configure terminal
  interface eth1
    ip address 10.10.1.2/30
    exit
  interface eth2
    ip address 10.10.1.10/30
    exit
  interface eth3
    ip address 192.168.1.1/24
    end

Ada tiga (3) elemen dasar konfigurasi OSPF:

  • Enable OSPF instance
  • OSPF area configuration
  • OSPF network configuration


Catatan: Ingat bahwa backbone area-id adalah 0.0.0.0.

R1

vtysh
configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf
  network 10.10.1.0/30 area 0.0.0.0
  network 10.10.1.4/30 area 0.0.0.0
  end

R2

vtysh
configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf
  network 10.10.1.4/30 area 0.0.0.0
  network 10.10.1.8/30 area 0.0.0.0
  network 172.16.0.0/16 area 0.0.0.0
  end

R3

vtysh
configure terminal
  !
  ! area 0 = backbone
  router ospf
  network 10.10.1.0/30 area 0.0.0.0
  network 10.10.1.8/30 area 0.0.0.0
  network 192.168.1.0/24 area 0.0.0.0
  end

Verify

Cek di R1, R2, R3

show ip ospf route
show ip ospf neighbor
show ip ospf database 
show ip route


ping 10.10.1.1
ping 10.10.1.2
ping 10.10.1.5
ping 10.10.1.6
ping 10.10.1.9
ping 10.10.1.10
ping 192.168.1.1
ping 172.16.1.1

Referensi


Pranala Menarik