Quagga: OSPF Multi-area network

From OnnoWiki
Jump to navigation Jump to search
Image6006.gif

Topology Jaringan

R1:

eth1: -- R2: eth1
eth2: -- R3: eth1

R2:

eth1: -- R1: eth1
eth2: -- R4: eth1
eth3: -- nat0: Internet

R3:

eth1: -- R1: eth2
eth2: -- LAN: 192.168.1.1/24

R4:

eth1: -- R2: eth2
eth2: -- LAN: 192.168.2.1/24


Setup IP address

R1:

vtysh
configure terminal
  interface eth1
    ip address 10.0.1.1/30
    no shutdown
    exit
  interface eth2
    ip address 10.1.1.1/30
    no shutdown
    exit
 end

R2:

vtysh
configure terminal
  interface eth1
    ip address 10.0.1.2/30
    no shutdown
    exit
  interface eth2
    ip address 10.1.2.1/30
    no shutdown
    exit
  !
  ! NAT GNS3 gw 192.168.122.1
  interface eth3
    ip address 192.168.122.100/24
    ip address 192.168.122.101/24
    ip address 192.168.122.102/24
    no shutdown
    ip route 0.0.0.0 0.0.0.0 192.168.122.1
  end

R3:

vtysh
configure terminal
  interface eth1
    ip address 10.1.1.2/30
    no shutdown
    exit
  interface eth2
    ip address 192.168.1.1/24
    no shutdown
    exit
  end

R4:

vtysh
configure terminal
  interface eth1
    ip address 10.1.2.2/30
    no shutdown
    exit
  interface eth2
    ip address 192.168.2.1/24
    no shutdown
    exit
  end

Setup OSPF

R1:

configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf
  network 10.0.1.0/30 area 0.0.0.0
  network 10.1.1.0/30 area 0.0.0.1
  end

R2:

configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf
  network 10.0.1.0/30 area 0.0.0.0
  network 10.1.2.0/30 area 0.0.0.2
  end

R3:

configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf
  network 10.1.1.0/30 area 0.0.0.1
  network 192.168.1.0/24 area 0.0.0.1
  end

R4:

configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf
  network 10.1.2.0/30 area 0.0.0.2
  network 192.168.2.0/24 area 0.0.0.2
  end

Cek route

Cek R1, R2, R3, R4:

show ip ospf neighbor
show ip ospf database 
show ip route

Redistribute Connected

R3:

enable
configure terminal
router ospf 3
  redistribute connected
  end

R4:

enable
configure terminal
router ospf 4
  redistribute connected
  end


Cek

show ip ospf neighbor
show ip ospf database 
show ip route

Youtube

Pranala Menarik