OpenWRT IPv6: Membuat Gateway 6to4

From OnnoWiki
Jump to navigation Jump to search

Sumber: http://wiki.openwrt.org/doc/howto/barrier.breaker.ipv6.6to4


If you are like most people, native ipv6 is not going to happen any time soon; you may also not want to setup a tunnel with a broker because of various limitations. Now assuming you can ping 192.88.99.1, you can also traceroute to make sure it's nearby, 6to4 automatic tunnels will work for you. After this configuration even if your public ip address changes it will update itself and handle everything for you.

https://en.wikipedia.org/wiki/6to4
opkg update;opkg install 6to4

Next you need to create the 6to4 interface

vi /etc/config/network
config interface 6rd 
     option proto 6to4 
     option adv_subnet 1
     option adv_interface lan

You need to install radvd to configure your workstations

opkg install radvd

Unfortunately radvd doesn't configure properly for me. So create a new file:

vi /etc/radvd.conf
interface br-lan
{
MaxRtrAdvInterval 30;
AdvLinkMTU 1280;
IgnoreIfMissing on;
AdvSendAdvert on;
AdvManagedFlag off;
AdvOtherConfigFlag off;

prefix 0:0:0:1::/64
  { 
	AdvValidLifetime 300; 
	AdvPreferredLifetime 120;
	AdvOnLink on;
	AdvAutonomous on;
	Base6to4Interface eth0.2;
  };
};

After this you need to configure radvd to use the new configuration. Add the following to the bottom of the config.

vi /etc/config/radvd
config 'radvd'
  option 'config_file' '/etc/radvd.conf'

You need to allow iptables to handle the ipv6 interface created earlier. Find the existing wan option and in 'option network' you need to add in 6rd so that it looks like the following.

vi /etc/config/firewall
config zone 
  option name 'wan' 
  option network 'wan 6rd'
  option input REJECT 
  option forward REJECT 
  option output ACCEPT 
  option masq 1

You need to add in a new rule as well.

vi /etc/config/firewall
config rule
  option target 'ACCEPT' 
  option name '6to4' 
  option src 'wan' 
  option proto '41'

You are done. Reboot your router and you should be able to use ipv6 networks.



Referensi