Mikrotik: OSPF Sederhana distribute default routing

From OnnoWiki
Jump to navigation Jump to search
Image6006.gif

Topology Jaringan

R1:

eth0: -- R2: eth0
eth1: -- R3: eth0

R2:

eth0: -- R1: eth0
eth1: -- R4: eth0
eth2: -- nat0: Internet

R3:

eth0: -- R1: eth1
eth1: -- LAN: 192.168.1.1/24

R4:

eth0: -- R2: eth1
eth1: -- LAN: 192.168.2.1/24

Setup IP address

R1:

/ip address add address=10.0.1.1/30 interface=ether1
/ip address add address=10.1.1.1/30 interface=ether2

R2:


/ip address add address=10.0.1.2/30 interface=ether1
/ip address add address=10.1.2.1/30 interface=ether2
/ip address add address=192.168.122.100/24 interface=ether3
/ip address add address=192.168.122.101/24 interface=ether3
/ip address add address=192.168.122.102/24 interface=ether3
/ip dhcp-client add interface=ether3 disabled=no        # kalau ether3 DHCP client
/ip firewall nat add chain=srcnat out-interface=ether3 action=masquerade 
/ip firewall nat print
/ip route add dst-address=0.0.0.0/0 gateway=192.168.122.1

R3:

/ip address add address=10.1.1.2/30 interface=ether1
/ip address add address=192.168.1.1/24 interface=ether2

R4:

/ip address add address=10.1.2.2/30 interface=ether1
/ip address add address=192.168.2.1/24 interface=ether2

Setup OSPF

R1:

/routing ospf instance enable default
/routing ospf area add name=area1 area-id=0.0.0.1
/routing ospf network add network=10.0.1.0/24 area=backbone
/routing ospf network add network=10.1.1.0/30 area=area1
/routing ospf interface 
   add interface=ether1 authentication=md5 authentication-key=$AP7i1 authentication-key-id=1
/routing ospf interface 
   add interface=ether2 authentication=md5 authentication-key=$AP7i1 authentication-key-id=1

R2:

/routing ospf instance enable default
/routing ospf area add name=area2 area-id=0.0.0.2
/routing ospf network add network=10.0.1.0/24 area=backbone
/routing ospf network add network=10.1.2.0/30 area=area2
/routing ospf interface 
   add interface=ether1 authentication=md5 authentication-key=$AP7i1 authentication-key-id=1
/routing ospf interface 
   add interface=ether2 authentication=md5 authentication-key=$AP7i1 authentication-key-id=1


/routing ospf instance set distribute-default=if-installed-as-type-1 numbers=0


R3 configuration:

/routing ospf instance enable default
/routing ospf area add name=area1 area-id=0.0.0.1
/routing ospf network add network=10.1.1.0/30 area=area1
/routing ospf network add network=192.168.1.0/24 area=area1
/routing ospf interface 
   add interface=ether1 authentication=md5 authentication-key=$AP7i1 authentication-key-id=1

R4 configuration:

/routing ospf instance enable default
/routing ospf area add name=area2 area-id=0.0.0.2
/routing ospf network add network=10.1.2.0/30 area=area2
/routing ospf network add network=192.168.2.0/24 area=area2
/routing ospf interface 
   add interface=ether1 authentication=md5 authentication-key=$AP7i1 authentication-key-id=1

Cek route

R3:

/routing ospf interface print
/routing ospf neighbor print
/ip route print 
    

Redistribute Connected

/routing ospf instance set 0 redistribute-connected=as-type-1 
/routing ospf instance print 

Cek

/routing ospf interface print
/routing ospf neighbor print
/ip route print

Pranala Menarik