Mikrotik: OSPF Sederhana - dengan MD5 Authentication

From OnnoWiki
Jump to navigation Jump to search
Image6005.gif

Sambungan

R1
eth0: -- R3: eth0
eth1: -- R2: eth0
eth2: -- Internet
R2:
eth0: -- R1: eth1
eth1: -- R3: eth1
eth2: -- LAN 172.16.1.1/16
R3:
eth0: -- R1: eth0
eth1: -- R2: eth1
eth2: -- LAN 192.168.1.1/24


IP address

Router1:

/ip address add address=10.10.1.1/30 interface=ether1
/ip address add address=10.10.1.5/30 interface=ether2
/ip address add address=192.168.122.100/24 interface=ether3
/ip address add address=192.168.122.101/24 interface=ether3
/ip address add address=192.168.122.102/24 interface=ether3
# /ip dhcp-client add interface=ether3 disabled=no        # kalau ether3 DHCP client
/ip firewall nat add chain=srcnat out-interface=ether3 action=masquareade
/ip firewall nat print

Router2:

/ip address add address=10.10.1.6/30 interface=ether1
/ip address add address=10.10.1.9/30 interface=ether2
/ip address add address=172.16.1.1/16 interface=ether3

Router3:

/ip address add address=10.10.1.2/30 interface=ether1
/ip address add address=10.10.1.10/30 interface=ether2
/ip address add address=192.168.1.1/24 interface=ether3

OSPF

Ada tiga (3) elemen dasar konfigurasi OSPF:

  • Enable OSPF instance
  • OSPF area configuration
  • OSPF network configuration

instance name=default sudah ada, tidak perlu di tambahkan, tapi kalau perlu menambahkan caranya adalah sebagai berikut Catatan: Ingat bahwa backbone area-id adalah 0.0.0.0.


R1:

# /routing ospf instance add name=default
/routing ospf instance set name=default router-id=10.10.1.1 numbers=0 
/routing ospf instance enable numbers=0
/routing ospf network add network=10.10.1.0/30 area=backbone
/routing ospf network add network=10.10.1.4/30 area=backbone 
/routing ospf interface 
   add interface=ether1 authentication=md5 authentication-key=AP7i1 authentication-key-id=1
/routing ospf interface 
   add interface=ether2 authentication=md5 authentication-key=AP7i1 authentication-key-id=1

R2:

# /routing ospf instance add name=default
/routing ospf instance set name=default router-id=10.10.1.6 numbers=0
/routing ospf instance enable numbers=0
/routing ospf network add network=10.10.1.4/30 area=backbone 
/routing ospf network add network=10.10.1.8/30 area=backbone 
/routing ospf network add network=172.16.0.0/16 area=backbone
/routing ospf interface 
   add interface=ether1 authentication=md5 authentication-key=AP7i1 authentication-key-id=1
/routing ospf interface 
   add interface=ether2 authentication=md5 authentication-key=AP7i1 authentication-key-id=1

R3:

# /routing ospf instance add name=default
/routing ospf instance set name=default router-id=10.10.1.2 numbers=0
/routing ospf instance enable numbers=0
/routing ospf network add network=10.10.1.0/30 area=backbone 
/routing ospf network add network=10.10.1.8/30 area=backbone 
/routing ospf network add network=192.168.1.0/24 area=backbone
/routing ospf interface 
   add interface=ether1 authentication=md5 authentication-key=AP7i1 authentication-key-id=1
/routing ospf interface 
   add interface=ether2 authentication=md5 authentication-key=AP7i1 authentication-key-id=1

Cek

/routing ospf instance print 
Flags: X - disabled 
 0   name="default" router-id=10.10.1.1 distribute-default=never 
     redistribute-connected=as-type-1 redistribute-static=as-type-1 
     redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no 
     metric-default=1 metric-connected=20 metric-static=20 metric-rip=20 
     metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in out-filter=ospf-out

Verify

Cek

R1:

/routing ospf interface print
/routing ospf neighbor print
/ip route print

Lakukan yang sama untuk R2, R3


Referensi


Pranala Menarik