Mikrotik: BGP dengan Quagga

From OnnoWiki
Jump to: navigation, search
Bgp-multihoming.png

Ada tiga (3) ISP

ISP1:

IP 192.168.1.1/24 menuju ISP3
IP 192.168.3.1/24 menuju ISP2
AS 10
IP 10.100.100.0/24
IP 10.100.200.0/24

ISP2

IP 192.168.2.1/24 - menuju ISP3
IP 192.168.3.2/24 - menuju ISP1
AS 20
IP 10.10.10.0/24
IP 10.10.20.0/24

ISP3 (kita)

IP 192.168.1.2/24 - menuju ISP1
IP 192.168.2.2/24 - menuju ISP2
AS 30
IP 10.1.1.0/24
IP 10.1.2.0/24 


Sambungan Fisik

ISP1 e0 -> ISP3 e0
ISP1 e1 -> ISP2 e1
ISP2 e0 -> ISP3 e1

ISP1 e2 10.100.100.1/24
ISP1 e3 10.100.200.1/24

ISP2 e2 10.10.10.1/24
ISP2 e3 10.10.20.1/24

ISP3 e2 10.1.1.1/24
ISP3 e3 10.1.2.1/24


Setup connection

ISP1

/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=192.168.3.1/24 interface=ether2 
/ip address add address=10.100.100.1/24 interface=ether3
/ip address add address=10.100.200.1/24 interface=ether4

ISP2

vtysh
enable
configure terminal
  interface eth0
    ip address 192.168.2.1/24
    link-detect
    exit
  interface eth1
    ip address 192.168.3.2/24
    link-detect
    exit
  interface eth2
    ip address 10.10.10.1/24
    link-detect
    exit
  interface eth3
    ip address 10.10.20.1/24
    link-detect
    exit

ISP3

vtysh
enable
configure terminal
  interface eth0
    ip address 192.168.1.2/24
    link-detect
    exit
  interface eth1
    ip address 192.168.2.2/24
    link-detect
    exit
  interface eth2
    ip address 10.1.1.1/24
    link-detect
    exit
  interface eth3
    ip address 10.1.2.1/24
    link-detect
    exit

BGP Peering

Consider that IP connectivity between ISPs edge routers and Our Core router is already set up and working properly. So we can start to establish BGP peering to both ISPs.


ISP1:

#set our AS number
/routing bgp instance set default as=10
#add BGP peers
/routing bgp peer
add name=toISP2 remote-address=192.168.3.2 remote-as=20
add name=toISP3 remote-address=192.168.1.2 remote-as=30
# jika ingin redistribute default route ke client yang spesifik
# add name=toISP2 remote-address=192.168.3.2 remote-as=20 default-originate=if-installed
# add name=toISP3 remote-address=192.168.1.2 remote-as=30 default-originate=if-installed
/routing bgp network
add network=10.100.100.0/24 synchronize=no
add network=10.100.200.0/24 synchronize=no

ISP2:


router bgp 20
 bgp router-id 192.168.2.1
 neighbor 192.168.3.1 remote-as 10
 neighbor 192.168.2.2 remote-as 30
 network 10.10.10.0/24
 network 10.10.20.0/24

ISP3:

router bgp 30
 bgp router-id 192.168.2.2
 neighbor 192.168.1.1 remote-as 10
 neighbor 192.168.2.1 remote-as 20
 network 10.1.1.0/24
 network 10.1.2.0/24



Referensi


Pranala Menarik