Mikrotik: BGP Sederhana tanpa filter

From OnnoWiki
Jump to: navigation, search
Bgp-multihoming.png

Ada tiga (3) ISP

ISP1:

IP 192.168.1.1/24 menuju ISP3
IP 192.168.3.1/24 menuju ISP2
AS 10
IP 10.100.100.0/24
IP 10.100.200.0/24

ISP2

IP 192.168.2.1/24 - menuju ISP3
IP 192.168.3.2/24 - menuju ISP1
AS 20
IP 10.10.10.0/24
IP 10.10.20.0/24

ISP3 (kita)

IP 192.168.1.2/24 - menuju ISP1
IP 192.168.2.2/24 - menuju ISP2
AS 30
IP 10.1.1.0/24
IP 10.1.2.0/24 


Sambungan Fisik

ISP1 e0 -> ISP3 e0
ISP1 e1 -> ISP2 e1
ISP2 e0 -> ISP3 e1

ISP1 e2 10.100.100.1/24
ISP1 e3 10.100.200.1/24

ISP2 e2 10.10.10.1/24
ISP2 e3 10.10.20.1/24

ISP3 e2 10.1.1.1/24
ISP3 e3 10.1.2.1/24


Setup connection

ISP1

/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=192.168.3.1/24 interface=ether2 
/ip address add address=10.100.100.1/24 interface=ether3
/ip address add address=10.100.200.1/24 interface=ether4

ISP2

/ip address add address=192.168.2.1/24 interface=ether1 
/ip address add address=192.168.3.2/24 interface=ether2
/ip address add address=10.10.10.1/24 interface=ether3
/ip address add address=10.10.20.1/24 interface=ether4

ISP3

/ip address add address=192.168.1.2/24 interface=ether1 
/ip address add address=192.168.2.2/24 interface=ether2
/ip address add address=10.1.1.1/24 interface=ether3
/ip address add address=10.1.2.1/24 interface=ether4

BGP Peering

Consider that IP connectivity between ISPs edge routers and Our Core router is already set up and working properly. So we can start to establish BGP peering to both ISPs.


ISP1:

#set our AS number
/routing bgp instance set default as=10
#add BGP peers
/routing bgp peer
add name=toISP2 remote-address=192.168.3.2 remote-as=20
add name=toISP3 remote-address=192.168.1.2 remote-as=30
# jika ingin redistribute default route ke client yang spesifik
# add name=toISP2 remote-address=192.168.3.2 remote-as=20 default-originate=if-installed
# add name=toISP3 remote-address=192.168.1.2 remote-as=30 default-originate=if-installed

ISP2:


#set our AS number
/routing bgp instance set default as=20
#add BGP peers
/routing bgp peer
add name=toISP1 remote-address=192.168.3.1 remote-as=10
add name=toISP3 remote-address=192.168.2.2 remote-as=30

ISP3:

#set our AS number
/routing bgp instance set default as=30
#add BGP peers
/routing bgp peer
add name=toISP1 remote-address=192.168.1.1 remote-as=10
add name=toISP2 remote-address=192.168.2.1 remote-as=20

Network Advertisements and Routing Filters

Now we can start to advertise our networks and filter out all other unnecessary advertisements.

ISP1:

/routing bgp network
add network=10.100.100.0/24 synchronize=no
add network=10.100.200.0/24 synchronize=no


ISP2:

/routing bgp network
add network=10.10.10.0/24 synchronize=no
add network=10.10.20.0/24 synchronize=no

ISP3:

First step is to advertise our networks

/routing bgp network
add network=10.1.1.0/24 synchronize=no
add network=10.1.2.0/24 synchronize=no

Cek

/routing filter print
/routing bgp instance print
/routing bgp peer print status
/routing bgp peer print
/routing bgp advertisements print 
/ip route print

Referensi


Pranala Menarik