Mikrotik: BGP 2 link ke 3 BGP redistribute 2 OSPF

From OnnoWiki
Jump to navigation Jump to search
3BGP-2OSPF.png


Ada tiga (3) ISP

ISP1:

IP 192.168.1.1/24 menuju ISP3
IP 192.168.3.1/24 menuju ISP2
AS 10
IP 10.100.100.0/24
IP 10.100.200.0/24

ISP2

IP 192.168.2.1/24 - menuju ISP3
IP 192.168.3.2/24 - menuju ISP1
AS 20
IP 10.10.10.0/24
IP 10.10.20.0/24

ISP3 (kita)

IP 192.168.1.2/24 - menuju ISP1
IP 192.168.2.2/24 - menuju ISP2
AS 30
IP 10.1.1.0/24
IP 10.1.2.0/24 

R4

IP 10.1.1.2/24 menuju ISP3
IP 172.16.1.1  menuju R5
IP 172.16.10.1 LAN
IP 172.16.20.1 LAN

R5

IP 10.1.2.2/24 menuju ISP3
IP 172.16.1.2  menuju R4
IP 172.16.100.1/24 LAN
IP 172.16.200.1/24 LAN


Sambungan Fisik

ISP1


ISP1 Eth1/0 -> ISP3 Eth1/0
ISP1 Eth1/1 -> ISP2 Eth1/1
ISP2 Eth1/0 -> ISP3 Eth1/1

ISP1 Eth1/2 10.100.100.1/24
ISP1 Eth1/3 10.100.200.1/24

ISP2 Eth1/2 10.10.10.1/24
ISP2 Eth1/3 10.10.20.1/24

ISP3 Eth1/2 10.1.1.1/24
ISP3 Eth1/3 10.1.2.1/24


Setup connection

ISP1

/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=192.168.3.1/24 interface=ether2 
/ip address add address=10.100.100.1/24 interface=ether3
/ip address add address=10.100.200.1/24 interface=ether4

ISP2

/ip address add interface=ether1 address=192.168.2.1/24
/ip address add interface=ether2 address=192.168.3.2/24
/ip address add interface=ether3 address=10.10.10.1/24
/ip address add interface=ether4 address=10.10.20.1/24

ISP3

/ip address add interface=ether1 address=192.168.1.2/24
/ip address add interface=ether2 address=192.168.2.2/24
/ip address add interface=ether3 address=10.1.1.1/24
/ip address add interface=ether4 address=10.1.2.1/24

R4

/ip address add interface=ether1 address=10.1.1.2/24
/ip address add interface=ether2 address=172.16.1.1/24
/ip address add interface=ether3 address=172.16.10.1/24
/ip address add interface=ether4 address=172.16.20.1/24

R5

/ip address add interface=ether1 address=10.1.2.2/24
/ip address add interface=ether2 address=172.16.1.2/24
/ip address add interface=ether3 address=172.16.100.1/24
/ip address add interface=ether4 address=172.16.200.1/24


BGP Peering

Consider that IP connectivity between ISPs edge routers and Our Core router is already set up and working properly. So we can start to establish BGP peering to both ISPs.


ISP1:

#set our AS number
/routing bgp instance set default as=10
#add BGP peers
/routing bgp peer
add name=toISP2 remote-address=192.168.3.2 remote-as=20
add name=toISP3 remote-address=192.168.1.2 remote-as=30
# jika ingin redistribute default route ke client yang spesifik
# add name=toISP2 remote-address=192.168.3.2 remote-as=20 default-originate=if-installed
# add name=toISP3 remote-address=192.168.1.2 remote-as=30 default-originate=if-installed
#
# advertize routing
#
/routing bgp network
add network=10.100.100.0/24 synchronize=no
add network=10.100.200.0/24 synchronize=no

ISP2:

#set our AS number
/routing bgp instance set default as=20
#add BGP peers
/routing bgp peer
add name=toISP1 remote-address=192.168.3.1 remote-as=10
add name=toISP3 remote-address=192.168.2.2 remote-as=30
#
# advertize routing
#
/routing bgp network
add network=10.10.10.0/24 synchronize=no
add network=10.10.20.0/24 synchronize=no

Main / Backup Link Setup di ISP3

Lakukan

  • accept network kita sendiri
  • drop semua tabel IP lainnya, karena kita tidak mau menjadi transit provider
  • BGP AS prepend - menaikan AS path ke salah satu ISP (disini ISP1)


ISP3:

#set our AS number
/routing bgp instance
  set default as=30
  redistribute-connected=yes
  redistribute-ospf=yes
#add BGP peers
/routing bgp peer
  add name=toISP1 remote-address=192.168.1.1 remote-as=10
  add name=toISP2 remote-address=192.168.2.1 remote-as=20
#
# advertize network
#
/routing bgp network
add network=10.1.1.0/24 synchronize=no
add network=10.1.2.0/24 synchronize=no 

OSPF

ISP3

# /routing ospf instance add name=default 
/routing ospf instance set name=default router-id=10.1.1.1 numbers=0 redistribute-bgp=yes
/routing ospf instance enable numbers=0
/routing ospf network add network=10.1.1.0/24 area=backbone 
/routing ospf network add network=10.1.2.0/24 area=backbone 


R4

# /routing ospf instance add name=default 
/routing ospf instance set name=default router-id=10.1.1.2 numbers=0
/routing ospf instance enable numbers=0
/routing ospf network add network=10.1.1.0/24 area=backbone 
/routing ospf network add network=172.16.1.0/24 area=backbone 
/routing ospf network add network=172.16.10.0/24 area=backbone 
/routing ospf network add network=172.16.20.0/24 area=backbone 

R5

# /routing ospf instance add name=default 
/routing ospf instance set name=default router-id=10.1.2.2 numbers=0
/routing ospf instance enable numbers=0
/routing ospf network add network=10.1.2.0/24 area=backbone 
/routing ospf network add network=172.16.1.0/24 area=backbone 
/routing ospf network add network=172.16.100.0/24 area=backbone 
/routing ospf network add network=172.16.200.0/24 area=backbone


Cek

/routing filter print
/routing bgp instance print
/routing bgp peer print status
/routing bgp peer print
/routing bgp advertisements print 
/ip route print


Referensi



Pranala Menarik