IPv6: Quagga: OSPF Sederhana

From OnnoWiki
Jump to navigation Jump to search

ERROR:

  • IPv4 OSPF OK
  • IPv6 OSPF6 - routing tidak ter-broadcast ke neighbor


Image6005.gif

Topologi

R1

e1 -- R3: e1
e2 -- R2: e1
e3 -- NAT: Internet

R2

e1 -- R2: e1
e2 -- R3: e2
e3 -- LAN 172.16.1.1

R3

e1 -- R1: e1
e2 -- R2: e2
e3 -- LAN 192.168.1.1


Konfigurasi Interface

Router1:

vtysh
configure terminal
  ! ipv6 forwarding
  interface eth1
    ip address 10.10.1.1/30
    ipv6 address 2001:10:10:1::1/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 1
    no shutdown
    exit
  ! ipv6 forwarding
  interface eth2
    ip address 10.10.1.5/30
    ipv6 address 2001:10:10:5::1/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 2
    no shutdown
    exit
  !
  ! NAT GNS3 gw 192.168.122.1
  ! ipv6 forwarding
  interface eth3
    ip address 192.168.122.100/24
    ip address 192.168.122.101/24
    ip address 192.168.122.102/24
    no shutdown
    ip route 0.0.0.0/0 192.168.122.1
  end

Router2:

vtysh
configure terminal
  ! ipv6 forwarding
  interface eth1
    ip address 10.10.1.6/30
    ipv6 address 2001:10:10:5::2/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 1
    no shutdown
    exit
  ! ipv6 forwarding
  interface eth2
    ip address 10.10.1.9/24
    ipv6 address 2001:10:10:9::1/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 2
    no shutdown
    exit
  ! ipv6 forwarding
  interface eth3
    ip address 172.16.1.1/16
    ipv6 address 2001:172:16:1::1/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 3
    no shutdown
    end

Router3:

vtysh
configure terminal
  ! ipv6 forwarding
  interface eth1
    ip address 10.10.1.2/30
    ipv6 address 2001:10:10:1::2/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 1
    no shutdown
    exit
  ! ipv6 forwarding
  interface eth2
    ip address 10.10.1.10/30
    ipv6 address 2001:10:10:9::2/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 2
    no shutdown
    exit
  ! ipv6 forwarding
  interface eth3
    ip address 192.168.1.1/24
    ipv6 address 2001:192:168:1::1/64
    ipv6 ospf6 network broadcast
    ipv6 ospf6 instance-id 3
    no shutdown
    end

Konfigurasi OSPF

Ada tiga (3) elemen dasar konfigurasi OSPF:

  • Enable OSPF instance
  • OSPF area configuration
  • OSPF network configuration

Catatan: Ingat bahwa backbone area-id adalah 0.0.0.0.

R1

vtysh
configure terminal
  router-id 10.10.1.1
  router ospf
    network 10.10.1.0/30 area 0.0.0.0
    network 10.10.1.4/30 area 0.0.0.0
    exit
  router ospf6
    log-adjacency-changes 
    router-id 10.10.1.1
    interface eth1 area 0.0.0.0
    interface eth2 area 0.0.0.0 
    interface eth3 area 0.0.0.0 
    area 0.0.0.0 range 2001:10:10:1::/64
    area 0.0.0.0 range 2001:10:10:5::/64
    redistribute connected 
    redistribute kernel    
    redistribute static 
  end

R2

vtysh
configure terminal
  router-id 10.10.1.5
  router ospf
    network 10.10.1.4/30 area 0.0.0.0
    network 10.10.1.8/30 area 0.0.0.0
    network 172.16.0.0/16 area 0.0.0.0
    exit
  router ospf6
    log-adjacency-changes 
    router-id 10.10.1.5
    interface eth1 area 0.0.0.0 
    interface eth2 area 0.0.0.0
    interface eth3 area 0.0.0.0  
    area 0.0.0.0 range 2001:10:10:5::/64
    area 0.0.0.0 range 2001:10:10:9::/64
    area 0.0.0.0 range 2001:172:16:1::/64
    redistribute connected 
    redistribute kernel    
    redistribute static 
  end

R3

vtysh
configure terminal
  router-id 10.10.1.2
  router ospf
    network 10.10.1.0/30 area 0.0.0.0
    network 10.10.1.8/30 area 0.0.0.0
    network 192.168.1.0/24 area 0.0.0.0
    exit
  router ospf6
    log-adjacency-changes 
    router-id 10.10.1.2
    interface eth1 area 0.0.0.0 
    interface eth2 area 0.0.0.0 
    interface eth3 area 0.0.0.0 
    area 0.0.0.0 range 2001:10:10:1::/64
    area 0.0.0.0 range 2001:10:10:9::/64
    area 0.0.0.0 range 2001:192:168:1::/64
    redistribute connected 
    redistribute kernel    
    redistribute static 
  end

Verify

Cek di R1, R2, R3

show ipv6 ospf6 
show ipv6 ospf6 neighbor
show ipv6 ospf6 database
show ipv6 route ospf6
show ipv6 route
show ip ospf neighbor
show ip ospf database 
show ip route


ping x:x:x:x::x - ipv6

Referensi

Pranala Menarik