IPv6: Quagga: OSPF Multi-area network

From OnnoWiki
Jump to navigation Jump to search

ERROR:

  • IPv4 OSPF OK
  • IPv6 OSPF6 - routing tidak ter-broadcast ke neighbor


Image6006.gif

Topology Jaringan

R1:

eth1: -- R2: eth1
eth2: -- R3: eth1

R2:

eth1: -- R1: eth1
eth2: -- R4: eth1
eth3: -- nat0: Internet

R3:

eth1: -- R1: eth2
eth2: -- LAN: 192.168.1.1/24

R4:

eth1: -- R2: eth2
eth2: -- LAN: 192.168.2.1/24

Setup IP address

R1:

vtysh
configure terminal
  interface eth1
    ip address 10.0.1.1/24
    ipv6 address 2001:10:0:1::1/64
    ipv6 ospf6 instance-id 1 
    no shutdown
    exit
  interface eth2
    ip address 10.1.1.1/24
    ipv6 address 2001:10:1:1::1/64
    ipv6 ospf6 instance-id 1 
    no shutdown
    exit
 end

R2:

vtysh
configure terminal
  interface eth1
    ip address 10.0.1.2/24
    ipv6 address 2001:10:0:1::2/64
    ipv6 ospf6 instance-id 2
    no shutdown
    exit
  interface eth2
    ip address 10.1.2.1/24
    ipv6 address 2001:10:1:2::1/64
    ipv6 ospf6 instance-id 2
    no shutdown
    exit
  !
  ! NAT GNS3 gw 192.168.122.1
  interface eth3
    ip address 192.168.122.100/24
    ipv6 address 2001:192:168:122::100/64
    ipv6 ospf6 instance-id 2
    no shutdown
    ip route 0.0.0.0 0.0.0.0 192.168.122.1
  end

R3:

vtysh
configure terminal
  interface eth1
    ip address 10.1.1.2/24
    ipv6 address 2001:10:1:1::2/64
    ipv6 ospf6 instance-id 3
    no shutdown
    exit
  interface eth2
    ip address 192.168.1.1/24
    ipv6 address 2001:192:168:1::1/64
    ipv6 ospf6 instance-id 3
    no shutdown
    exit
  end

R4:

vtysh
configure terminal
  interface eth1
    ip address 10.1.2.2/24
    ipv6 address 2001:10:1:2::2/64
    ipv6 ospf6 instance-id 4
    no shutdown
    exit
  interface eth2
    ip address 192.168.2.1/24
    ipv6 address 2001:192:168:2::1/64
    ipv6 ospf6 instance-id 4
    no shutdown
    exit
  end

Setup OSPF

R1:

vtysh
configure terminal
  router ospf
    router-id 10.1.1.1
    network 10.0.1.0/24 area 0.0.0.0
    network 10.1.1.0/24 area 0.0.0.1
  router ospf6
    router-id 10.1.1.1
    area 0.0.0.0 range 2001:10:0:1::/64
    area 0.0.0.1 range 2001:10:1:1::/64
    interface eth1 area 0.0.0.0
    interface eth2 area 0.0.0.1
  end

R2:

vtysh
configure terminal
  router ospf
    router-id 10.1.2.1
    network 10.0.1.0/24 area 0.0.0.0
    network 10.1.2.0/24 area 0.0.0.2
  router ospf6
    router-id 10.1.2.1
    area 0.0.0.0 range 2001:10:0:1::/64
    area 0.0.0.2 range 2001:10:1:2::/64
    interface eth1 area 0.0.0.0
    interface eth2 area 0.0.0.2
   end

R3 configuration:

vtysh
configure terminal
  router ospf
    router-id 192.168.1.1
    network 10.1.1.0/24 area 0.0.0.1
    network 192.168.1.0/24 area 0.0.0.1
  router ospf6
    router-id 192.168.1.1
    area 0.0.0.1 range 2001:10:1:1::/64
    area 0.0.0.1 range 2001:192:168:1::/64
    interface eth1 area 0.0.0.1
    interface eth2 area 0.0.0.1
   end

R4 configuration:

vtysh
configure terminal
  router ospf
    router-id 192.168.1.1
    network 10.1.2.0/24 area 0.0.0.2
    network 192.168.2.0/24 area 0.0.0.2
  router ospf6
    router-id 192.168.2.1
    area 0.0.0.2 range 2001:10:1:2::/64
    area 0.0.0.2 range 2001:192:168:2::/64
    interface eth1 area 0.0.0.2
    interface eth2 area 0.0.0.2
  end

Cek route

Cek R1, R2, R3, R4:

show ip ospf neighbor
show ip ospf database 
show ip route
show ipv6 ospf interface
show ipv6 ospf 
show ipv6 ospf neighbor 
show ipv6 ospf database 
show ipv6 route


Redistribute Connected

R3:

enable
configure terminal
router ospf 3
  redistribute connected
  end

R4:

enable
configure terminal
router ospf 4
  redistribute connected
  end


Cek

show ip ospf neighbor
show ip ospf database 
show ip route

Youtube

Pranala Menarik