IPv6: Quagga: BGP Sederhana tanpa filter

From OnnoWiki
Jump to navigation Jump to search
Bgp-multihoming.png

Ada tiga (3) ISP

ISP1:

IP 192.168.1.1/24 menuju ISP3
IP 192.168.3.1/24 menuju ISP2
AS 10
IP 10.100.100.0/24
IP 10.100.200.0/24

ISP2

IP 192.168.2.1/24 - menuju ISP3
IP 192.168.3.2/24 - menuju ISP1
AS 20
IP 10.10.10.0/24
IP 10.10.20.0/24

ISP3 (kita)

IP 192.168.1.2/24 - menuju ISP1
IP 192.168.2.2/24 - menuju ISP2
AS 30
IP 10.1.1.0/24
IP 10.1.2.0/24 


Topologi

ISP1

ISP1 e0 -> ISP3 e0
ISP1 e1 -> ISP2 e1
ISP2 e0 -> ISP3 e1

ISP1 e2 10.100.100.1/24
ISP1 e3 10.100.200.1/24

ISP2 e2 10.10.10.1/24
ISP2 e3 10.10.20.1/24

ISP3 e2 10.1.1.1/24
ISP3 e3 10.1.2.1/24

Setup connection

ISP1

vtysh
configure terminal
  interface eth0
    ip address 192.168.1.1/24
    ipv6 address 2001:192:168:1::1/64
    no shutdown
    exit
  interface eth1
    ip address 192.168.3.1/24
    ipv6 address 2001:192:168:3::1/64
    no shutdown
    exit
  interface eth2
    ip address 10.100.100.1/24
    ipv6 address 2001:10:100:100::1/64
    no shutdown
    exit
  interface eth3
    ip address 10.100.200.1/24
    ipv6 address 2001:10:100:200::1/64
    no shutdown
    exit
 end

ISP2

vtysh
configure terminal
  interface eth0
    ip address 192.168.2.1/24
    ipv6 address 2001:192:168:2::1/64
    no shutdown
    exit
  interface eth1
    ip address 192.168.3.2/24
    ipv6 address 2001:192:168:3::2/64
    no shutdown
    exit
  interface eth2
    ip address 10.10.10.1/24
    ipv6 address 2001:10:10:10::1/64
    no shutdown
    exit
  interface eth3
    ip address 10.10.20.1/24
    ipv6 address 2001:10:10:20::1/64
    no shutdown
    exit
 end

ISP3

vtysh
configure terminal
  interface eth0
    ip address 192.168.1.2/24
    ipv6 address 2001:192:168:1::2/64
    no shutdown
    exit
  interface eth1
    ip address 192.168.2.2/24
    ipv6 address 2001:192:168:2::2/64
    no shutdown
    exit
  interface eth2
    ip address 10.1.1.1/24
    ipv6 address 2001:10:1:1::1/64
    no shutdown
    exit
  interface eth3
    ip address 10.1.2.1/24
    ipv6 address 2001:10:1:2::1/64
    no shutdown
    exit
 end

BGP Peering

Consider that IP connectivity between ISPs edge routers and Our Core router is already set up and working properly. So we can start to establish BGP peering to both ISPs.


ISP1:

vtysh
configure terminal
  router bgp 10
  ! no bgp default ipv4-unicast
  bgp router-id 192.168.1.1
    !
    neighbor 2001:192:168:3::2 remote-as 20
      address-family ipv6 unicast
        network 2001:10:100:100::/64
        network 2001:10:100:200::/64
      neighbor 2001:192:168:3::2 activate 
    neighbor 192.168.3.2 remote-as 20
      ! address-family ipv4 unicast 
      network 10.100.100.0/24
      network 10.100.200.0/24
      neighbor 192.168.3.2 activate 
    !
    neighbor 2001:192:168:1::2 remote-as 30
      address-family ipv6 unicast
        network 2001:10:100:100::/64
        network 2001:10:100:200::/64
      neighbor 2001:192:168:1::2 activate 
    neighbor 192.168.1.2 remote-as 30
      network 10.100.100.0/24
      network 10.100.200.0/24
      neighbor 192.168.1.2 activate
  end


ISP2:

vtysh
configure terminal
  router bgp 20
  ! no bgp default ipv4-unicast
  bgp router-id 192.168.2.1
    neighbor 2001:192:168:3::1 remote-as 10
      address-family ipv6 unicast
        network 2001:10:10:10::/64
        network 2001:10:10:20::/64
      neighbor 2001:192:168:3::1 activate
    neighbor 192.168.3.1 remote-as 10
      ! address-family ipv4 unicast 
      network 10.10.10.0/24
      network 10.10.20.0/24
      neighbor 192.168.3.1 activate
    !
    neighbor 2001:192:168:2::2 remote-as 30
      address-family ipv6 unicast
        network 2001:10:10:10::/64
        network 2001:10:10:20::/64
      neighbor 2001:192:168:2::2 activate 
    neighbor 192.168.2.2 remote-as 30
      ! address-family ipv4 unicast 
      network 10.10.10.0/24
      network 10.10.20.0/24
      neighbor 192.168.2.2 activate 
  end

ISP3:

vtysh
configure terminal
  router bgp 30
  ! no bgp default ipv4-unicast
  bgp router-id 192.168.1.2
    neighbor 2001:192:168:1::1 remote-as 10
      address-family ipv6 unicast
        network 2001:10:1:1::/64
        network 2001:10:1:2::/64
      neighbor 2001:192:168:1::1 activate
    neighbor 192.168.1.1 remote-as 10
      ! address-family ipv4 unicast 
      network 10.1.1.0/24
      network 10.1.2.0/24
      neighbor 192.168.1.1 activate
    neighbor 2001:192:168:2::1 remote-as 20
      address-family ipv6 unicast
        network 2001:10:1:1::/64
        network 2001:10:1:2::/64
      neighbor 2001:192:168:2::1 activate  
    neighbor 192.168.2.1 remote-as 20
      ! address-family ipv4 unicast 
      network 10.1.1.0/24
      network 10.1.2.0/24
      neighbor 192.168.2.1 activate
  end

Cek

show ip route
show ip bgp 10.100.1000.0/24
show ip bgp neighbors 192.168.2.2 advertised-routes
show ip bgp neighbor 192.168.1.1 routes
show bgp ipv4 unicast neighbors 
show bgp ipv4 unicast summary
show ipv6 route
show ipv6 bgp summary
show ipv6 route  
show bgp summary 
show bgp ipv6 unicast neighbors
show bgp ipv6 unicast summary


Client

Pengganti PC untuk IPv6 yang kecil dan baik untuk VirtualBox adalah OpenWRT.

PC1

ifconfig eth0 2001:10:100:100::100/64
route add -A inet6 default gw 2001:10:100:100::1
ifconfig eth0 up
ping 2001:10:100:100::1
ping 2001:10:100:100::100
ping 2001:10:10:10::1
ping 2001:10:10:10::100
ping 2001:10:1:1::1
ping 2001:10:1:1::100

PC2


ifconfig eth0 2001:10:10:10::100/64
route add -A inet6 default gw 2001:10:10:10::1
ifconfig eth0 up
ping 2001:10:100:100::1
ping 2001:10:100:100::100
ping 2001:10:10:10::1
ping 2001:10:10:10::100
ping 2001:10:1:1::1
ping 2001:10:1:1::100

PC3


ifconfig eth0 2001:10:1:1::100/64
route add -A inet6 default gw 2001:10:1:1::1
ifconfig eth0 up
ping 2001:10:100:100::1
ping 2001:10:100:100::100
ping 2001:10:10:10::1
ping 2001:10:10:10::100
ping 2001:10:1:1::1
ping 2001:10:1:1::100

Referensi

Pranala Menarik