IPv6: Mikrotik: type unreachable

From OnnoWiki
Jump to navigation Jump to search

sumber: https://forum.mikrotik.com/viewtopic.php?t=123724

This is best practice anyway, even w/o dynamic routing:

On the router with the pool, create a static route type=unreachable with the /48. This is so that traffic bound for unassigned addresses within that pool should get sinkholed at the pool router. Since the pool is routed to this one router, it's safe to assume that if this router has no route for any given address, that address must not exist, ergo it should be discarded.

/ipv6 route add dst=2001:db8:cafe::/48 type=unreachable

This also integrates quite nicely with dynamic routing:

Configure the pool router to redistribute static routes into OSPF. This will originate the /48 prefix into OSPF for you, which will trigger BGP to originate the /48 into BGP. For extra benefit, you can set up a filter for ospf-out on the pool router which drops sub-prefixes of the /48 so that you only have the one prefix in your OSPF table. e.g.:

/routing rule
add chain=My-ospf-Filter prefix=2001:db8:cafe::/48 prefix-length=49-128 action=discard
add chain=My-ospf-Filter action=accept


Referensi


Pranala Menarik