IPv6: Mikrotik: OSPF over GRE Tunnel

From OnnoWiki
Jump to navigation Jump to search

SUmber: https://forum.mikrotik.com/viewtopic.php?t=68950

IPSec can't transfer multicast traffic, so it is not possible to configure IPSec policy for it. Instead, you can use GRE6 tunnel between your routers and add this GRE interfaces to OSPF-v3. For example, if we have two routers, R1 and R2 with IPv6 addresses 2001:db8::1 and 2001:db8::2, instead of adding ether1 interfaces to OSPF-v3, R1 configuration could be: Code: Select all

/ipv6 address
add address=2001:db8::1 interface=ether1
/interface gre6
add ipsec-secret="Secret!" local-address=2001:db8::1 name=gre-12 \
    remote-address=2001:db8::2
/routing ospf-v3 interface
add area=backbone interface=gre-12 network-type=point-to-point

And R2 configuration could be:


/ipv6 address
add address=2001:db8::2 interface=ether1
/interface gre6
add ipsec-secret="Secret!" local-address=2001:db8::2 name=gre-21 \
    remote-address=2001:db8::1
/routing ospf-v3 interface
add area=backbone interface=gre-21 network-type=point-to-point


Referensi