IPv6: Dynamic Tunnel 6to4

From OnnoWiki
Jump to navigation Jump to search


R1,

/interface ethernet set ether1 disabled=no
/interface ethernet set ether2 disabled=no
/interface ethernet set ether3 disabled=no
/ip address add address=12.12.12.1/24 interface=ether1
/ip address add address=13.13.13.1/24 interface=ether2
/ip address add address=14.14.14.1/24 interface=ether3
/routing ospf instance set 0 disabled=no
/routing ospf network add area=backbone network=12.12.12.0/24
/routing ospf network add area=backbone network=13.13.13.0/24
/routing ospf network add area=backbone network=14.14.14.0/24

R2,

/interface ethernet set ether1 disabled=no
/interface ethernet set ether2 disabled=no
/ip address add address=12.12.12.2/24 interface=ether1
/ipv6 address add address=2001:1:2:3::1/64 interface=ether2 advertise=yes
/routing ospf instance set 0 disabled=no
/routing ospf network add area=backbone network=12.12.12.0/24

R3,

/interface ethernet set ether1 disabled=no
/interface ethernet set ether2 disabled=no
/ip address add address=13.13.13.3/24 interface=ether1
/ipv6 address add address=2001:4:5:6::1/64 interface=ether2 advertise=yes
/routing ospf instance set 0 disabled=no
/routing ospf network add area=backbone network=13.13.13.0/24

R4,

/interface ethernet set ether1 disabled=no
/interface ethernet set ether2 disabled=no
/ip address add address=14.14.14.4/24 interface=ether1
/ipv6 address add address=2001:7:8:9::1/64 interface=ether2 advertise=yes
/routing ospf instance set 0 disabled=no
/routing ospf network add area=backbone network=14.14.14.0/24

Selanjutnya kita konfigurasikan 6to4 tunnel pada R2 dan R3

http://www.kloth.net/services/iplocate.php https://www.whatsmydns.net/ipv4-to-ipv6?q=12.12.12.2


R2,

/interface 6to4
add disabled=no local-address=12.12.12.2 name=tunnel0 remote-address=unspecified
/ipv6 address
add address=2002:c0c:c02::/64 advertise=no disabled=no eui-64=no interface=tunnel0
/ipv6 address
add address=2001:222::1/64 advertise=no disabled=no eui-64=no interface=tunnel0



R3,

/interface 6to4
add disabled=no local-address=13.13.13.3 name=tunnel0 remote-address=unspecified
/ipv6 address
add address=2002:0d0d:0d03::/64 advertise=no disabled=no eui-64=no interface=tunnel0
/ipv6 address
add address=2001:333::1/64 advertise=no disabled=no eui-64=no interface=tunnel0


R4,

/interface 6to4
add disabled=no local-address=14.14.14.4 name=tunnel0 remote-address=unspecified
/ipv6 address
add address=2002:0e0e:0e04::/64 advertise=no disabled=no eui-64=no interface=tunnel0
/ipv6 address
add address=2001:444::1/64 advertise=no disabled=no eui-64=no interface=tunnel0


Set Dynamic Routing

R2,

/ipv6 route add dst-address=2002::/16 gateway=tunnel0
/routing ospf-v3 instance add router-id=0.0.0.2
/routing ospf-v3 interface add interface=tunnel0 area=backbone network-type=ptmp 
/routing ospf-v3 interface add interface=ether2 area=backbone network-type=ptmp 


R3,

/ipv6 route add dst-address=2002::/16 gateway=tunnel0
/routing ospf-v3 instance add router-id=0.0.0.3
/routing ospf-v3 interface add interface=tunnel0 area=backbone network-type=ptmp 
/routing ospf-v3 interface add interface=ether2 area=backbone network-type=ptmp 

R4,

/ipv6 route add dst-address=2002::/16 gateway=tunnel0
/routing ospf-v3 instance add router-id=0.0.0.4
/routing ospf-v3 interface add interface=tunnel0 area=backbone network-type=ptmp 
/routing ospf-v3 interface add interface=ether2 area=backbone network-type=ptmp 



Set Static routing

R2,

/ipv6 route add dst-address=2002::/16 gateway=tunnel0
/ipv6 route add dst-address=2001:4:5:6::/64 gateway=2002:0d0d:0d03::
/ipv6 route add dst-address=2001:7:8:9::/64 gateway=2002:0e0e:0e04::
/ipv6 route add dst-address=2001:333::/64 gateway=2002:0d0d:0d03::
/ipv6 route add dst-address=2001:444::/64 gateway=2002:0e0e:0e04::


R3

/ipv6 route add dst-address=2002::/16 gateway=tunnel0
/ipv6 route add dst-address=2001:1:2:3::/64 gateway=2002:0c0c:0c02::
/ipv6 route add dst-address=2001:7:8:9::/64 gateway=2002:0e0e:0e04::
/ipv6 route add dst-address=2001:222::/64 gateway=2002:0c0c:0c02::
/ipv6 route add dst-address=2001:444::/64 gateway=2002:0e0e:0e04::

R4,

/ipv6 route add dst-address=2002::/16 gateway=tunnel0
/ipv6 route add dst-address=2001:1:2:3::/64 gateway=2002:0c0c:0c02::
/ipv6 route add dst-address=2001:4:5:6::/64 gateway=2002:0d0d:0d03::
/ipv6 route add dst-address=2001:222::/64 gateway=2002:0c0c:0c02::
/ipv6 route add dst-address=2001:333::/64 gateway=2002:0d0d:0d03::




Cek

R2

/interface 6to4 print detail where name=tunnel0
/ipv6 route print
/ping 2001:4:5:6::1
/ping 2001:7:8:9::1

R3

/interface 6to4 print detail where name=tunnel0
/ipv6 route print
/ping 2001:1:2:3::1
/ping 2001:7:8:9::1

R4,

/interface 6to4 print detail where name=tunnel0
/ipv6 route print
/ping 2001:1:2:3::1
/ping 2001:4:5:6::1
/ping 2001:7:8:9::1


Setup Virtual PC

VPC1

ip 2001:1:2:3::100/64 2001:1:2:3::1

VPC2

ip 2001:4:5:6::100/64 2001:4:5:6::1

VPC3

ip 2001:7:8:9::100/64 2001:7:8:9::1

Cek

ping 2001:1:2:3::1
ping 2001:1:2:3::100
ping 2001:4:5:6::1
ping 2001:4:5:6::100
ping 2001:7:8:9::1
ping 2001:7:8:9::100