IPv6: Cisco: OSPF Howto

From OnnoWiki
Jump to navigation Jump to search

Configuring the OSPFv3 Router Process

enable
configure terminal
  router ospfv3 [process-id]
  area area-ID [default-cost | nssa | stub]
  auto-cost reference-bandwidth Mbps
  bfd all-interfaces
  default {area area-ID [range ipv6-prefix | virtual-link router-id]} [default-information originate [always | metric | metric-type | route-map] | distance | distribute-list prefix-list prefix-list-name {in | out} [interface] | maximum-paths paths | redistribute protocol | summary-prefix ipv6-prefix]
  ignore lsa mospf
  interface-id snmp-if-index
  log-adjacency-changes [detail]
  passive-interface [default | interface-type interface-number]
  queue-depth {hello | update} {queue-size | unlimited}
  router-id router-id


ipv6 router ospf 1
 router-id 10.11.11.1
 area 1 range 2001:DB8::/48

Configuring the IPv6 Address Family in OSPFv3

enable
configure terminal
  router ospfv3 [process-id]
  address-family ipv6 unicast
  area area-ID range ipv6-prefix / prefix-length
  default {area area-ID [range ipv6-prefix | virtual-link router-id]} [default-information originate [always | metric | metric-type | route-map] | distance | distribute-list prefix-list prefix-list-name {in | out} [interface] | maximum-paths paths | redistribute protocol | summary-prefix ipv6-prefix]
  default-information originate [always ] metric metric-value | metric-type type-value | route-map map-name
  default-metric metric-value
  distance distance
  distribute-list prefix-list list-name {in [interface-type interface-number] | out routing-process [as-number]}
  maximum-paths number-paths
  summary-prefix prefix [not-advertise | tag tag-value] 

Configuring the IPv4 Address Family in OSPFv3

enable
configure terminal
  router ospfv3 [process-id]
  address-family ipv4 unicast
  area area-id range ip-address ip-address-mask [advertise | not-advertise] [cost cost]
  default {area area-ID[range ipv6-prefix | virtual-link router-id]} [default-information originate [always | metric | metric-type | route-map] | distance | distribute-list prefix-list prefix-list-name {in | out} [interface] | maximum-paths paths | redistribute protocol | summary-prefix ipv6-prefix]
  default-information originate [always] metric metric-value | metric-type type-value | route-map map-name
  default-metric metric-value
  distance distance
  distribute-list prefix-list list-name {in [interface-type interface-number] | out routing-process [as-number]}
  maximum-paths number-paths
  summary-prefix prefix [not-advertise | tag tag-value] 

Configuring Route Redistribution in OSPFv3

enable
configure terminal
  router ospfv3 [process-id]
  address-family ipv6 unicast
  redistribute source-protocol [process-id] [options] 

Enabling OSPFv3 on an Interface

enable
configure terminal
  interface type number
  #  Do one of the following:
  #
  ospfv3 process-id area area-ID {ipv4 | ipv6} [instance instance-id]
  ipv6 ospf process-id area area-id [instance instance-id]

Defining an OSPFv3 Area Range

enable
configure terminal
  ipv6 router ospf process-id
  area area-id range ipv6-prefix / prefix-length [ advertise | not-advertise] [cost cost] 

Configuring the OSPFv3 Max-Metric Router LSA

enable
configure terminal
  router ospfv3 process-id
  max-metric router-lsa [external-lsa [max-metric-value]] [include-stub] [inter-area-lsas [max-metric-value]] [on-startup {seconds | wait-for-bgp}] [prefix-lsa] [stub-prefix-lsa [max-metric-value]] [summary-lsa [max-metric-value]]
  exit
show ospfv3 [process-id] max-metric 


Contoh

Ospfv3-config-guide-01.gif


Stub Router

ipv6 unicast-routing
ipv6 cef
!
interface serial 0/0
 no ip address
 ipv6 enable
 ipv6 address 2001:ABAB::/64 eui-64
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 3.3.3.3
 area 2 stub
!


ABR1 Router

ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 speed auto
 ipv6 address 2003::1/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2002:ABAB::/64 eui-64
 ipv6 enable
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 1.1.1.1
 area 2 stub no-summary
!

ASBR Router

ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 ipv6 address 2003::2/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:1/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router ospf 1
 router-id 2.2.2.2
 default-metric 25
 redistribute rip EXT metric-type 1 include-connected
!
ipv6 router rip EXT
 redistribute ospf 1 match internal external 1 external 2 include-connected
!

External Router

ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address 2004:ABAB::/64 eui-64
 ipv6 enable
 ipv6 rip EXT enable
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:2/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router rip EXT


Referensi

Pranala Menarik