IPv6: Cisco: BGP Dua Link main backup

From OnnoWiki
Jump to navigation Jump to search

ERROR:

R3(config-router)#     neighbor 2001:198:168:1::1 route-map PREPEND out
% Specify remote-as or peer-group commands first



Bgp-multihoming.png

Ada tiga (3) ISP

ISP1:

IP 192.168.1.1/24 menuju ISP3
IP 192.168.3.1/24 menuju ISP2
AS 10
IP 10.100.100.0/24
IP 10.100.200.0/24

ISP2

IP 192.168.2.1/24 - menuju ISP3
IP 192.168.3.2/24 - menuju ISP1
AS 20
IP 10.10.10.0/24
IP 10.10.20.0/24

ISP3 (kita)

IP 192.168.1.2/24 - menuju ISP1
IP 192.168.2.2/24 - menuju ISP2
AS 30
IP 10.1.1.0/24
IP 10.1.2.0/24 


Sambungan Fisik

ISP1

ISP1 Eth1/0 -> ISP3 Eth1/0
ISP1 Eth1/1 -> ISP2 Eth1/1
ISP2 Eth1/0 -> ISP3 Eth1/1

ISP1 Eth1/2 10.100.100.1/24
ISP1 Eth1/3 10.100.200.1/24

ISP2 Eth1/2 10.10.10.1/24
ISP2 Eth1/3 10.10.20.1/24

ISP3 Eth1/2 10.1.1.1/24
ISP3 Eth1/3 10.1.2.1/24

Setup connection

ISP1

enable
configure terminal
  ipv6 unicast-routing
  interface Ethernet1/0
    ip address 192.168.1.1 255.255.255.0
    ipv6 address 2001:192:168:1::1/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/1
    ip address 192.168.3.1 255.255.255.0
    ipv6 address 2001:192:168:3::1/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/2
    ip address 10.100.100.1 255.255.255.0
    ipv6 address 2001:10:100:100::1/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/3
    ip address 10.100.200.1 255.255.255.0
    ipv6 address 2001:10:100:200::1/64
    no shutdown
    exit
 end

ISP2

enable
configure terminal
  ipv6 unicast-routing
  interface Ethernet1/0
    ip address 192.168.2.1 255.255.255.0
    ipv6 address 2001:192:168:2::1/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/1
    ip address 192.168.3.2 255.255.255.0
    ipv6 address 2001:192:168:3::2/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/2
    ip address 10.10.10.1 255.255.255.0
    ipv6 address 2001:10:10:10::1/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/3
    ip address 10.10.20.1 255.255.255.0
    ipv6 address 2001:10:10:20::1/64
    no shutdown
    exit
 end

ISP3

enable
configure terminal
  ipv6 unicast-routing
  interface Ethernet1/0
    ip address 192.168.1.2 255.255.255.0
    ipv6 address 2001:192:168:1::2/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/1
    ip address 192.168.2.2 255.255.255.0
    ipv6 address 2001:192:168:2::2/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/2
    ip address 10.1.1.1 255.255.255.0
    ipv6 address 2001:10:1:1::1/64
    no shutdown
    exit
  ipv6 unicast-routing
  interface Ethernet1/3
    ip address 10.1.2.1 255.255.255.0
    ipv6 address 2001:10:1:2::1/64
    no shutdown
    exit
 end

BGP Peering

Consider that IP connectivity between ISPs edge routers and Our Core router is already set up and working properly. So we can start to establish BGP peering to both ISPs.


ISP1:

enable
configure terminal
  router bgp 10
  ! no bgp default ipv4-unicast
  bgp router-id 192.168.1.1
    !
    neighbor 2001:192:168:3::2 remote-as 20
      address-family ipv6 unicast
        network 2001:10:100:100::/64
        network 2001:10:100:200::/64
      neighbor 2001:192:168:3::2 activate 
    neighbor 192.168.3.2 remote-as 20
      ! address-family ipv4 unicast 
      network 10.100.100.0 mask 255.255.255.0
      network 10.100.200.0 mask 255.255.255.0
      neighbor 192.168.3.2 activate 
    !
    neighbor 2001:192:168:1::2 remote-as 30
      address-family ipv6 unicast
        network 2001:10:100:100::/64
        network 2001:10:100:200::/64
      neighbor 2001:192:168:1::2 activate 
    neighbor 192.168.1.2 remote-as 30
      network 10.100.100.0 mask 255.255.255.0
      network 10.100.200.0 mask 255.255.255.0
      neighbor 192.168.1.2 activate
  end


ISP2:

enable
configure terminal
  router bgp 20
  ! no bgp default ipv4-unicast
  bgp router-id 192.168.2.1
    neighbor 2001:192:168:3::1 remote-as 10
      address-family ipv6 unicast
        network 2001:10:10:10::/64
        network 2001:10:10:20::/64
      neighbor 2001:192:168:3::1 activate
    neighbor 192.168.3.1 remote-as 10
      ! address-family ipv4 unicast 
      network 10.10.10.0 mask 255.255.255.0
      network 10.10.20.0 mask 255.255.255.0
      neighbor 192.168.3.1 activate
    !
    neighbor 2001:192:168:2::2 remote-as 30
      address-family ipv6 unicast
        network 2001:10:10:10::/64
        network 2001:10:10:20::/64
      neighbor 2001:192:168:2::2 activate 
    neighbor 192.168.2.2 remote-as 30
      ! address-family ipv4 unicast 
      network 10.10.10.0 mask 255.255.255.0
      network 10.10.20.0 mask 255.255.255.0
      neighbor 192.168.2.2 activate 
  end

Main / Backup Link Setup di ISP3

Lakukan

  • accept network kita sendiri
  • drop semua tabel IP lainnya, karena kita tidak mau menjadi transit provider
  • BGP AS prepend - menaikan AS path ke salah satu ISP (disini ISP1)


ISP3:

enable
configure terminal
  router bgp 30
  ! no bgp default ipv4-unicast
  bgp router-id 192.168.1.2
    !
    neighbor 2001:192:168:1::1 remote-as 10
    address-family ipv6 unicast
      network 2001:10:1:1::/64
      network 2001:10:1:2::/64
    neighbor 2001:192:168:1::1 activate
    neighbor 192.168.1.1 remote-as 10
    ! address-family ipv4 unicast 
    network 10.1.1.0 mask 255.255.255.0
    network 10.1.2.0 mask 255.255.255.0
    neighbor 192.168.1.1 activate
    !
    neighbor 2001:192:168:2::1 remote-as 20
      address-family ipv6 unicast
        network 2001:10:1:1::/64
        network 2001:10:1:2::/64
      neighbor 2001:192:168:2::1 activate
    !
    neighbor 192.168.2.1 remote-as 20
      ! address-family ipv4 unicast 
      network 10.1.1.0 mask 255.255.255.0
      network 10.1.2.0 mask 255.255.255.0
      neighbor 192.168.2.1 activate
  end


enable
configure terminal
  router bgp 30
    route-map PREPEND permit 10
    set as-path prepend 30 30 30 30 30
    exit
  router bgp 30
    neighbor 2001:192:168:1::1 remote-as 10
    neighbor 2001:198:168:1::1 route-map PREPEND out
    neighbor 192.168.1.1 remote-as 10
    neighbor 198.168.1.1 route-map PREPEND out

Cek

! perhatikan AS 30 di tambahkan 5x ke routing ke arah AS 10
!
show ip bgp
show ip route
show ip bgp 10.100.1000.0/24
show ip bgp neighbors 192.168.2.2 advertised-routes
show ip bgp neighbor 192.168.1.1 routes
show bgp ipv4 unicast neighbors 
show bgp ipv4 unicast summary
show ipv6 neighbors 
show ipv6 route
show bgp ipv6 unicast neighbors
show bgp ipv6 unicast summary

Referensi

Pranala Menarik