Cisco IPv6: Dynamic Tunnel IPv6 ISATAP

From OnnoWiki
Jump to navigation Jump to search
Dynamic-6to4-cisco.png


R1,

enable 
configure terminal
interface Ethernet 1/0
no shutdown
ip address 12.12.12.1 255.255.255.0
exit

interface Ethernet 1/1
no shutdown	
ip address 13.13.13.1 255.255.255.0 
exit

interface Ethernet 1/2
no shutdown	
ip address 14.14.14.1 255.255.255.0 
exit
router ospf 1
network 12.12.12.0 0.0.0.255 area 0 
network 13.13.13.0 0.0.0.255 area 0
network 14.14.14.0 0.0.0.255 area 0
exit

R2,

enable 
configure terminal
interface Ethernet 1/0
no shutdown 
ip address 12.12.12.2 255.255.255.0
exit

interface Ethernet 1/1
no shutdown
ipv6 address 2001:1:2:3::1/64
exit

router ospf 1
network 12.12.12.0 0.0.0.255 area 0
exit

R3,

enable 
configure terminal
interface Ethernet 1/0 
no shutdown 
ip address 13.13.13.3 255.255.255.0
exit

interface Ethernet 1/1
no shutdown
ipv6 address 2001:4:5:6::1/64 
exit

router ospf 1
network 13.13.13.0 0.0.0.255 area 0
exit 

R4,

enable 
configure terminal
interface Ethernet 1/0 
no shutdown 
ip address 14.14.14.4 255.255.255.0
exit

interface Ethernet 1/1
no shutdown
ipv6 address 2001:7:8:9::1/64 
exit

router ospf 1
network 14.14.14.0 0.0.0.255 area 0
exit 

Selanjutnya kita konfigurasikan 6to4 tunnel pada R2 dan R3

R2,

interface tunnel 0
ipv6 address 2000::/64 eui-64
tunnel source Ethernet 1/0 
tunnel mode ipv6ip isatap
exit

R3,

interface tunnel 0
ipv6 address 2000::/64 eui-64
tunnel source Ethernet 1/0 
tunnel mode ipv6ip isatap
exit

R4,

interface tunnel 0
ipv6 address 2000::/64 eui-64
tunnel source Ethernet 1/0 
tunnel mode ipv6ip isatap
exit

Cek IPv6 tunnel untuk routing

R2,

do show ipv6 interface brief
FastEthernet0/0            [administratively down/down]
    unassigned
Ethernet1/0                [up/up]
    unassigned
Ethernet1/1                [up/up]
    FE80::C802:34FF:FE9B:1D
    2001:1:2:3::1
Ethernet1/2                [administratively down/down]
    unassigned
....
Tunnel0                    [up/up]
    FE80::5EFE:C0C:C02
    2000::5EFE:C0C:C02

R3,

do show ipv6 interface brief
.....
2000::5EFE:D0D:D03

R4,

do show ipv6 interface brief
....
2000::5EFE:E0E:E04


Set routing

R2,

ipv6 unicast-routing
ipv6 route 2001:4:5:6::/64 2000::5EFE:D0D:D03
ipv6 route 2001:7:8:9::/64 2000::5EFE:E0E:E04

R3

ipv6 unicast-routing
ipv6 route 2001:1:2:3::/64 2000::5EFE:C0C:C02
ipv6 route 2001:7:8:9::/64 2000::5EFE:E0E:E04

R4,

ipv6 unicast-routing
ipv6 route 2001:1:2:3::/64 2000::5EFE:C0C:C02
ipv6 route 2001:4:5:6::/64 2000::5EFE:D0D:D03


Cek

R2

do show interface tunnel 0
do show ipv6 route
do ping 2001:4:5:6::1
do ping 2001:7:8:9::1

R3

do show interface tunnel 0
do show ipv6 route
do ping 2001:1:2:3::1
do ping 2001:7:8:9::1

R4,

do show interface tunnel 0
do show ipv6 route
do ping 2001:1:2:3::1
do ping 2001:4:5:6::1
do ping 2001:7:8:9::1


Setup Virtual PC

VPC1

 ip 2001:1:2:3::100/64 2001:1:2:3::1

VPC2

 ip 2001:4:5:6::100/64 2001:4:5:6::1

VPC3

 ip 2001:7:8:9::100/64 2001:7:8:9::1

Cek

ping 2001:1:2:3::1
ping 2001:1:2:3::100
ping 2001:4:5:6::1
ping 2001:4:5:6::100
ping 2001:7:8:9::1
ping 2001:7:8:9::100