Cisco: Tunnel IPv6

From OnnoWiki
Jump to navigation Jump to search
Static-Tunnel-Cisco.png


Tool yang digunakan

  • GNS3
  • 3 Router Cisco C7200
  • 1 Kali Linux
  • 1 Virtual PC

Sambungan:

  • R1 Ethernet 1/0 -> R2 Ethernet 1/0
  • R1 Ethernet 1/1 -> R3 Ethernet 1/0
  • R2 Ethernet 1/1 -> PC1
  • R3 Ethernet 1/1 -> PC2

Setup IP address

R1

enable
configure terminal
interface Ethernet 1/0
no shutdown 
ip address 12.12.12.1 255.255.255.0 
exit
interface Ethernet 1/1 
no shutdown
ip address 13.13.13.1 255.255.255.0 
exit

R2

enable
configure terminal
interface Ethernet 1/0
no shutdown
ip address 12.12.12.2 255.255.255.0
exit
interface Ethernet 1/1
no shutdown
ipv6 address 2001:1:2:3::1/64
exit

R3

enable
configure terminal
interface Ethernet 1/0 
no shutdown
ip address 13.13.13.3 255.255.255.0
exit
interface Ethernet 1/1
no shutdown
ipv6 address 2001:4:5:6::1/64
exit

check

do ping

Aktifkan OSPF di R1, R2, R3 agar IPv4 bisa komunikasi

R1

router ospf 1
network 12.12.12.0 0.0.0.255 area 0
network 13.13.13.0 0.0.0.255 area 0 
exit

R2

router ospf 1
network 12.12.12.0 0.0.0.255 area 0
exit

R3

router ospf 1 
network 13.13.13.0 0.0.0.255 area 0 
exit

Buat static tunnel antar R2 ke R3

R2

interface tunnel 0 
no shutdown
tunnel source 12.12.12.2
tunnel destination 13.13.13.3 
exit

R3

interface tunnel 0 
no shutdown
tunnel source 13.13.13.3
tunnel destination 12.12.12.2 
exit

Aktifkan IPv6 dan EIGRP dalam tunnel

R2

interface tunnel 0
ipv6 enable 
exit
ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
no shutdown
exit
interface tunnel 0 
ipv6 eigrp 1
exit
interface Ethernet 1/1 
ipv6 eigrp 1
exit

R3

interface tunnel 0 
ipv6 enable 
exit
ipv6 unicast-routing
ipv6 router eigrp 1 
eigrp router-id 3.3.3.3
no shutdown
exit
interface tunnel 0 
ipv6 eigrp 1 
exit
interface Ethernet 1/1
ipv6 eigrp 1 
exit

Cek

do ping
protocol[ip]: ipv6
Target IPv6 address: 2001:1:2:3::1


Konfigurasi VPC1 dan VPC2

VPC1

ip 2001:1:2:3::100/64 2001:1:2:3::1

VPC2

ip 2001:4:5:6::100/64 2001:4:5:6::1

Lakukan

VPC1

ping 2001:4:5:6::1
ping 2001:4:5:6::100

VPC2

ping 2001:1:2:3::1
ping 2001:1:2:3::100