Cisco: OSPF multi-area network - dengan MD5 Authentication

From OnnoWiki
Jump to navigation Jump to search
Image6006.gif

Topology Jaringan

R1:

eth1: -- R2: eth1
eth2: -- R3: eth1

R2:

eth1: -- R1: eth1
eth2: -- R4: eth1
eth3: -- nat0: Internet

R3:

eth1: -- R1: eth2
eth2: -- LAN: 192.168.1.1/24

R4:

eth1: -- R2: eth2
eth2: -- LAN: 192.168.2.1/24


Setup IP address

R1:

enable
configure terminal
  interface ethernet1/1
    ip address 10.0.1.1 255.255.255.252
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface ethernet1/2
    ip address 10.1.1.1 255.255.255.252
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
 end

R2:

enable
configure terminal
  interface ethernet1/1
    ip address 10.0.1.2 255.255.255.252
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface ethernet1/2
    ip address 10.1.2.1 255.255.255.252
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  !
  ! NAT GNS3 gw 192.168.122.1
  interface ethernet1/3
    ip address 192.168.122.100 255.255.255.0
    ip address 192.168.122.101 255.255.255.0 secondary
    ip address 192.168.122.102 255.255.255.0 secondary
    no shutdown
    ip route 0.0.0.0 0.0.0.0 192.168.122.1
  end

R3:

enable
configure terminal
  interface ethernet1/1
    ip address 10.1.1.2 255.255.255.252
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface ethernet1/2
    ip address 192.168.1.1 255.255.255.0
    no shutdown
    exit
  end

R4:

enable
configure terminal
  interface ethernet1/1
    ip address 10.1.2.2 255.255.255.252
    ip ospf message-digest-key 1 md5 $AP7i1
    no shutdown
    exit
  interface ethernet1/2
    ip address 192.168.2.1 255.255.255.0
    no shutdown
    exit
  end

Setup OSPF

R1:

enable
configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf 1
  network 10.0.1.0 0.0.0.3 area 0.0.0.0
  network 10.1.1.0 0.0.0.3 area 0.0.0.1
  area 0.0.0.0 authentication message-digest
  area 0.0.0.1 authentication message-digest
  end

R2:

enable
configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf 2
  network 10.0.1.0 0.0.0.3 area 0.0.0.0
  network 10.1.2.0 0.0.0.3 area 0.0.0.2
  area 0.0.0.0 authentication message-digest
  area 0.0.0.2 authentication message-digest
  end

R3 configuration:

enable
configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf 3
  network 10.1.1.0 0.0.0.3 area 0.0.0.1
  network 192.168.1.0 0.0.0.255 area 0.0.0.1
  area 0.0.0.1 authentication message-digest
  end

R4 configuration:

enable
configure terminal
  !
  ! area 0.0.0.0 = backbone
  router ospf 4
  network 10.1.2.0 0.0.0.3 area 0.0.0.2
  network 192.168.2.0 0.0.0.255 area 0.0.0.2
  area 0.0.0.2 authentication message-digest
  end

Cek route

Cek R1, R2, R3, R4:

show ip ospf neighbor
show ip ospf database 
show ip route

Redistribute Connected

R3:

enable
configure terminal
router ospf 3
  redistribute connected
  end

R4:

enable
configure terminal
router ospf 4
  redistribute connected
  end


Cek

show ip ospf neighbor
show ip ospf database 
show ip route

Pranala Menarik