Mikrotik: OSPF dengan Quagga

From OnnoWiki
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.
Image6005.gif

GNS3 Connector

R1 ethernet0 - R3 ethernet0
R1 ethernet1 - R2 ethernet0
R2 ethernet1 - R3 ethernet1
R2 ethernet2 - 172.16.1.1/16
R3 ethernet2 - 192.168.1.1/24


Konfigurasi

Router1:

/ip address add address=10.10.1.1/30 interface=ether1
/ip address add address=10.10.1.5/30 interface=ether2


/ip dhcp-client add interface=ether3 disabled=no        # kalau ether3 DHCP client
/ip firewall nat add chain=srcnat out-interface=ether3 action=masquareade
/ip firewall nat print


Router2 (Quagga):

vtysh
enable
configure terminal
  interface eth0
    ip address 10.10.1.6/30
    link-detect
    exit
  interface eth1
    ip address 10.10.1.9/30
    link-detect
    exit
  interface eth2
    ip address 172.16.1.1/16
    link-detect
    exit

Router3 (Quagga):

vtysh
enable
configure terminal
  interface eth0
    ip address 10.10.1.2/30
    link-detect
    exit
  interface eth1
    ip address 10.10.1.10/30
    link-detect
    exit
  interface eth2
    ip address 192.168.1.1/24
    link-detect
    exit


Ada tiga (3) elemen dasar konfigurasi OSPF:

  • Enable OSPF instance
  • OSPF area configuration
  • OSPF network configuration

instance name=default sudah ada, tidak perlu di tambahkan, tapi kalau perlu menambahkan caranya adalah sebagai berikut

R1:

/routing ospf instance enable default
/routing ospf network add network=10.10.1.0/30 area=backbone
/routing ospf network add network=10.10.1.4/30 area=backbone


R2:

router ospf
  ospf router-id 172.16.1.1
  redistribute connected
  network 10.10.1.4/30 area 0.0.0.0
  network 10.10.1.8/30 area 0.0.0.0
  network 172.16.0.0/16 area 0.0.0.0
  area 0.0.0.0 range 10.10.1.4/30
  area 0.0.0.0 range 10.10.1.8/30
  area 0.0.0.0 range 172.16.0.0/16

R3:

router ospf
  ospf router-id 192.168.1.1
  redistribute connected
  network 10.10.1.1/30 area 0.0.0.0
  network 10.10.1.8/30 area 0.0.0.0
  network 192.168.1.0/24 area 0.0.0.0
  area 0.0.0.0 range 10.10.1.1/30
  area 0.0.0.0 range 10.10.1.8/30
  area 0.0.0.0 range 192.168.1.0/24

Verify

Cek

R1:

/routing ospf interface print
/routing ospf neighbor print
/ip route print


R2 & R3

show ip route

Referensi


Pranala Menarik