Quagga: BGP Dua Link main backup - no transit filter-list

From OnnoWiki
Jump to navigation Jump to search
Bgp-multihoming.png

Ada tiga (3) ISP

ISP1:

IP 192.168.1.1/24 menuju ISP3
IP 192.168.3.1/24 menuju ISP2
AS 10
IP 10.100.100.0/24
IP 10.100.200.0/24

ISP2

IP 192.168.2.1/24 - menuju ISP3
IP 192.168.3.2/24 - menuju ISP1
AS 20
IP 10.10.10.0/24
IP 10.10.20.0/24

ISP3 (kita)

IP 192.168.1.2/24 - menuju ISP1
IP 192.168.2.2/24 - menuju ISP2
AS 30
IP 10.1.1.0/24
IP 10.1.2.0/24 


Sambungan Fisik

ISP1


ISP1 Eth0 -> ISP3 Eth0
ISP1 Eth1 -> ISP2 Eth1
ISP2 Eth0 -> ISP3 Eth1

ISP1 Eth2 10.100.100.1/24
ISP1 Eth3 10.100.200.1/24

ISP2 Eth2 10.10.10.1/24
ISP2 Eth3 10.10.20.1/24

ISP3 Eth2 10.1.1.1/24
ISP3 Eth3 10.1.2.1/24


Setup connection

ISP1

enable
configure terminal
  interface eth0
    ip address 192.168.1.1/24
    no shutdown
    exit
  interface eth1
    ip address 192.168.3.1/24
    no shutdown
    exit
  interface eth2
    ip address 10.100.100.1/24
    no shutdown
    exit
  interface eth3
    ip address 10.100.200.1/24
    no shutdown
    exit
 end

ISP2

enable
configure terminal
  interface eth0
    ip address 192.168.2.1/24
    no shutdown
    exit
  interface eth1
    ip address 192.168.3.2/24
    no shutdown
    exit
  interface eth2
    ip address 10.10.10.1/24
    no shutdown
    exit
  interface eth3
    ip address 10.10.20.1/24
    no shutdown
    exit
 end

ISP3

enable
configure terminal
  interface eth0
    ip address 192.168.1.2/24
    no shutdown
    exit
  interface eth1
    ip address 192.168.2.2/24
    no shutdown
    exit
  interface eth2
    ip address 10.1.1.1/24
    no shutdown
    exit
  interface eth3
    ip address 10.1.2.1/24
    no shutdown
    exit
 end

BGP Peering

Consider that IP connectivity between ISPs edge routers and Our Core router is already set up and working properly. So we can start to establish BGP peering to both ISPs.


ISP1:

enable
configure terminal
  router bgp 10
  bgp router-id 192.168.1.1
    network 10.100.100.0/24
    network 10.100.200.0/24
    neighbor 192.168.3.2 remote-as 20
    neighbor 192.168.1.2 remote-as 30
  end

ISP2:


enable
configure terminal
  router bgp 20
  bgp router-id 192.168.2.1
    network 10.10.10.0/24
    network 10.10.20.0/24
    neighbor 192.168.3.1 remote-as 10
    neighbor 192.168.2.2 remote-as 30
  end


Main / Backup Link Setup di ISP3

Lakukan

  • accept network kita sendiri
  • drop semua tabel IP lainnya, karena kita tidak mau menjadi transit provider
  • BGP filter-list hanya AS sendiri yang akan di broadcast


ISP3:

! apply ke neighbor
!
configure terminal
  ip as-path access-list 1 permit ^$
  router bgp 30
  neighbor 192.168.1.1 remote-as 10
  neighbor 192.168.1.1 filter-list 1 out
  neighbor 192.168.2.1 remote-as 20
  neighbor 192.168.2.1 filter-list 1 out
  network 10.1.1.0/24
  network 10.1.2.0/24
end

clear ip bgp 10
clear ip bgp 20

Cek

! perhatikan AS 30 di tambahkan 5x ke routing ke arah AS 10
!
clear ip bgp 10
clear ip bgp 20
!
show ip bgp


show ip route
show ip bgp 10.100.1000.0/24
show ip bgp neighbors 192.168.2.2 advertised-routes
show ip bgp neighbor 192.168.1.1 routes
show bgp ipv4 unicast neighbors 
show bgp ipv4 unicast summary

Referensi

Pranala Menarik