Cisco: BGP Dua Link main backup - dengan access list dan routemap

From OnnoWiki
Jump to navigation Jump to search
Bgp-multihoming.png

Ada tiga (3) ISP

ISP1:

IP 192.168.1.1/24 menuju ISP3
IP 192.168.3.1/24 menuju ISP2
AS 10
IP 10.100.100.0/24
IP 10.100.200.0/24

ISP2

IP 192.168.2.1/24 - menuju ISP3
IP 192.168.3.2/24 - menuju ISP1
AS 20
IP 10.10.10.0/24
IP 10.10.20.0/24

ISP3 (kita)

IP 192.168.1.2/24 - menuju ISP1
IP 192.168.2.2/24 - menuju ISP2
AS 30
IP 10.1.1.0/24
IP 10.1.2.0/24 


Sambungan Fisik

ISP1


ISP1 Eth1/0 -> ISP3 Eth1/0
ISP1 Eth1/1 -> ISP2 Eth1/1
ISP2 Eth1/0 -> ISP3 Eth1/1

ISP1 Eth1/2 10.100.100.1/24
ISP1 Eth1/3 10.100.200.1/24

ISP2 Eth1/2 10.10.10.1/24
ISP2 Eth1/3 10.10.20.1/24

ISP3 Eth1/2 10.1.1.1/24
ISP3 Eth1/3 10.1.2.1/24


Setup connection

ISP1

enable
configure terminal
  interface Ethernet1/0
    ip address 192.168.1.1 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/1
    ip address 192.168.3.1 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/2
    ip address 10.100.100.1 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/3
    ip address 10.100.200.1 255.255.255.0
    no shutdown
    exit
 end

ISP2

enable
configure terminal
  interface Ethernet1/0
    ip address 192.168.2.1 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/1
    ip address 192.168.3.2 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/2
    ip address 10.10.10.1 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/3
    ip address 10.10.20.1 255.255.255.0
    no shutdown
    exit
 end

ISP3

enable
configure terminal
  interface Ethernet1/0
    ip address 192.168.1.2 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/1
    ip address 192.168.2.2 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/2
    ip address 10.1.1.1 255.255.255.0
    no shutdown
    exit
  interface Ethernet1/3
    ip address 10.1.2.1 255.255.255.0
    no shutdown
    exit
 end

BGP Peering

Consider that IP connectivity between ISPs edge routers and Our Core router is already set up and working properly. So we can start to establish BGP peering to both ISPs.


ISP1:

enable
configure terminal
  router bgp 10
  bgp router-id 192.168.1.1
    ! address-family ipv4 unicast 
    network 10.100.100.0 mask 255.255.255.0
    network 10.100.200.0 mask 255.255.255.0
    neighbor 192.168.3.2 remote-as 20
    neighbor 192.168.1.2 remote-as 30
    neighbor 192.168.3.2 activate 
    neighbor 192.168.1.2 activate 
    ! neighbor 192.168.3.2 default-originate 
    ! neighbor 192.168.1.2 default-originate
  end

ISP2:


enable
configure terminal
  router bgp 20
  bgp router-id 192.168.2.1
    ! address-family ipv4 unicast
    network 10.10.10.0 mask 255.255.255.0
    network 10.10.20.0 mask 255.255.255.0
    neighbor 192.168.3.1 remote-as 10
    neighbor 192.168.2.2 remote-as 30
    neighbor 192.168.3.1 activate 
    neighbor 192.168.2.2 activate 
  end


Main / Backup Link Setup di ISP3

Lakukan

  • accept network kita sendiri
  • drop semua tabel IP lainnya, karena kita tidak mau menjadi transit provider
  • BGP AS prepend - menaikan AS path ke salah satu ISP (disini ISP1)


ISP3:

! set access list - hanya IP yang ada di access yang tabel routing-nya bisa lewat
!
configure terminal
  access-list 3 permit 10.100.100.0 0.0.0.255
  ! access-list 3 permit 10.100.200.0 0.0.0.255
  ! access-list 3 permit 10.10.10.0 0.0.0.255
  ! access-list 3 permit 10.10.20.0 0.0.0.255
  end
! definisikan route-map
configure terminal
  route-map NET3 permit 10
  match ip address 3
  set weight 100
  route-map NET3 permit 20
  end
!
! route-map NET3 permit 20 - terima routing lainnya, hanya access-list 3 di "set weight 100"
! apply ke neighbor
!
configure terminal
  router bgp 30
  neighbor 192.168.1.1 remote-as 10
  neighbor 192.168.1.1 route-map NET3 in
  neighbor 192.168.2.1 remote-as 20
  network 10.1.1.0 mask 255.255.255.0
  network 10.1.2.0 mask 255.255.255.0

clear ip bgp 10
clear ip bgp 20

Cek

! perhatikan AS 30 di tambahkan 5x ke routing ke arah AS 10
!
clear ip bgp 10
clear ip bgp 20
!
show ip bgp
   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.1.0/24      0.0.0.0                  0         32768 i
*> 10.1.2.0/24      0.0.0.0                  0         32768 i
*  10.10.10.0/24    192.168.1.1                            0 10 20 i
*>                  192.168.2.1              0             0 20 i
*  10.10.20.0/24    192.168.1.1                            0 10 20 i
*>                  192.168.2.1              0             0 20 i
*> 10.100.100.0/24  192.168.1.1              0           100 10 i
*                   192.168.2.1                            0 20 10 i
*> 10.100.200.0/24  192.168.1.1              0             0 10 i
*                   192.168.2.1                            0 20 10 i




show ip route
show ip bgp 10.100.1000.0/24
show ip bgp neighbors 192.168.2.2 advertised-routes
show ip bgp neighbor 192.168.1.1 routes
show bgp ipv4 unicast neighbors 
show bgp ipv4 unicast summary

Referensi

Pranala Menarik